DWQA 问题分类: 问题为何最新版本 CentOS 7.4.1708 依然默认使用 3.10 版本的内核?
centos铁粉centos铁粉 用户 提问于 1年 以前

刚开始用这系统的时候还以为是内核不稳定的原因,但是从 The Linux Kernel Archives 可以查得到 4.0 以上内核已经很稳定了。而使用旧版内核的话很多新硬件都用不了,不知道 CentOS 为什么要这么做?

centos铁粉畅网 用户 回复于 1年 以前

并不是最新的才是最好的,稳定压倒一切。

centos铁粉gyt 用户 回复于 1年 以前

LTS,long term stable,哟,

1 个回答
centos 用户 回答于 1年 以前

很简单,CentOS是红帽的克隆版,而红帽对系统的支持长达十年,现在6.x还在用2.6的内核,7.x会一直用3.10内核,4.x内核要等到8发布了。服务器操作系统本身以稳定为主。而红帽公司不卖系统,只卖服务。红帽公司的服务不仅系统本身,而是整个红帽软件仓库所有软件,如果内核变动太大,整个软件仓库的软件都要进行测试,这个工程量是非常巨大的。