Linux环境安装python3

Linux就该这么学

今天在阿里云买了一个Ecs来玩玩, 服务器是Linux版本, 登录服务器之后发现 python是python2.7,所以就打算自己安装一个python3。因为是安装完成之后才打算写这个文章的,所以安装截图就没有了,但是绝对步步都齐。

安装步骤如下:

(1)wget https://www.python.org/ftp/python/3.6.3/Python-3.6.3.tgz  下载安装包

(2)tar zxvf Python-3.6.3.tgz  解压安装包

(3)cd Python-3.6.3   转到该安装包目录下

(4)./configure --prefix=/usr/local/python36 这一步及其重要,对安装进行配置,并指定安装路径,安装路径不指定的话不利于后面的系统管理

(5) make 编译

(6) make install 安装

 

这样子就完成安装了,当然事情还没有完!!!且看下图

可以看到,默认输入python,还是python2.7,所以我们还需要一点工作,那就是建立软连接,使得系统默认的python版本是python3。有一点千万要记住,不要傻傻去卸载老版本,要不然后患无穷。

建立软连接:

(1)mv /usr/bin/python /usr/bin/python.bak

(2)ln -s /usr/local/python36/bin/python3.6 /usr/bin/python

这样配置之后,我们就会看到默认就是python36了:

 

大功告成~

本文由 CentOS中文站 - 专注Linux技术 作者:centos 发表,其版权均为 CentOS中文站 - 专注Linux技术 所有,文章内容系作者个人观点,不代表 CentOS中文站 - 专注Linux技术 对观点赞同或支持。如需转载,请注明文章来源。

付家弄全网通手机卖场xiaoniao

相关文章

评论:

2 条评论,访客:2 条,站长:0 条

0%好评

  • 好评:(0%)
  • 中评:(100%)
  • 差评:(0%)
  1. 付家弄全网通手机卖场
    付家弄全网通手机卖场发布于: 

    升级后有使用旧版本的软件会报错,需要修改备份原python版本的名称(python.bak):
    vim /usr/bin/yum 的第一行
    vim /usr/libexec/urlgrabber-ext-down 的第一行
    vim /usr/bin/firewall-cmd 的第一行
    vim /usr/sbin/firewalld 的第一行
    vim /usr/sbin/semanage 的第一行

  2. ZaneLee
    ZaneLee发布于: 
    评分:

    不应该去做软连接,那样的话好像yum的配置文件就要改解释器路径了。就应该让Python3和Python2共同存在。想要用3的时候就用python3命令就行了

发表评论

电子邮件地址不会被公开。 必填项已用*标注